re = /style=\"\s?.*?text-align:\s?(.*?);?\"|style=\'\s?.*?text-align:\s?(.*?);?\'/i
str = 'style="text-align: right"
style=\'text-align: right\'
style=\'text-align: right"
style="text-align: right\'
style="text-align:right"
style=\'text-align:right\'
style="text-align: right;"
style=\'text-align: right;\'
style=\'text-align: right;"
style="text-align: right;\'
style="text-align:right;"
style=\'text-align:right;\'
style="display: block; text-align: right"
style=\'display: block; text-align: right\'
style=\'display: block; text-align: right"
style="display: block; text-align: right\'
style="display: block; text-align:right"
style=\'display: block; text-align:right\'
style="display: block; text-align: right;"
style=\'display: block; text-align: right;\'
style=\'display: block; text-align: right;"
style="display: block; text-align: right;\'
style="display: block; text-align:right;"
style=\'display: block; text-align:right;\'
style="display: block;text-align: right"
style=\'display: block;text-align: right\'
style=\'display: block;text-align: right"
style="display: block;text-align: right\'
style="display: block;text-align:right"
style=\'display: block;text-align:right\'
style="display: block;text-align: right;"
style=\'display: block;text-align: right;\'
style=\'display: block;text-align: right;"
style="display: block;text-align: right;\'
style="display: block;text-align:right;"
style=\'display: block;text-align:right;\'
style="display:block;text-align: right"
style=\'display:block;text-align: right\'
style=\'display:block;text-align: right"
style="display:block;text-align: right\'
style="display:block;text-align:right"
style=\'display:block;text-align:right\'
style="display:block;text-align: right;"
style=\'display:block;text-align: right;\'
style=\'display:block;text-align: right;"
style="display:block;text-align: right;\'
style="display:block;text-align:right;"
style=\'display:block;text-align:right;\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end