using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"style=\""\s?.*?text-align:\s?(.*?);?\""|style=\'\s?.*?text-align:\s?(.*?);?\'";
string input = @"style=""text-align: right""
style='text-align: right'
style='text-align: right""
style=""text-align: right'
style=""text-align:right""
style='text-align:right'
style=""text-align: right;""
style='text-align: right;'
style='text-align: right;""
style=""text-align: right;'
style=""text-align:right;""
style='text-align:right;'
style=""display: block; text-align: right""
style='display: block; text-align: right'
style='display: block; text-align: right""
style=""display: block; text-align: right'
style=""display: block; text-align:right""
style='display: block; text-align:right'
style=""display: block; text-align: right;""
style='display: block; text-align: right;'
style='display: block; text-align: right;""
style=""display: block; text-align: right;'
style=""display: block; text-align:right;""
style='display: block; text-align:right;'
style=""display: block;text-align: right""
style='display: block;text-align: right'
style='display: block;text-align: right""
style=""display: block;text-align: right'
style=""display: block;text-align:right""
style='display: block;text-align:right'
style=""display: block;text-align: right;""
style='display: block;text-align: right;'
style='display: block;text-align: right;""
style=""display: block;text-align: right;'
style=""display: block;text-align:right;""
style='display: block;text-align:right;'
style=""display:block;text-align: right""
style='display:block;text-align: right'
style='display:block;text-align: right""
style=""display:block;text-align: right'
style=""display:block;text-align:right""
style='display:block;text-align:right'
style=""display:block;text-align: right;""
style='display:block;text-align: right;'
style='display:block;text-align: right;""
style=""display:block;text-align: right;'
style=""display:block;text-align:right;""
style='display:block;text-align:right;'";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}