#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)style=\"\s?.*?text-align:\s?(.*?);?\"|style=\'\s?.*?text-align:\s?(.*?);?\'"
Local $sString = "style="text-align: right"" & @CRLF & _
"style='text-align: right'" & @CRLF & _
"style='text-align: right"" & @CRLF & _
"style="text-align: right'" & @CRLF & _
"style="text-align:right"" & @CRLF & _
"style='text-align:right'" & @CRLF & _
"style="text-align: right;"" & @CRLF & _
"style='text-align: right;'" & @CRLF & _
"style='text-align: right;"" & @CRLF & _
"style="text-align: right;'" & @CRLF & _
"style="text-align:right;"" & @CRLF & _
"style='text-align:right;'" & @CRLF & _
"style="display: block; text-align: right"" & @CRLF & _
"style='display: block; text-align: right'" & @CRLF & _
"style='display: block; text-align: right"" & @CRLF & _
"style="display: block; text-align: right'" & @CRLF & _
"style="display: block; text-align:right"" & @CRLF & _
"style='display: block; text-align:right'" & @CRLF & _
"style="display: block; text-align: right;"" & @CRLF & _
"style='display: block; text-align: right;'" & @CRLF & _
"style='display: block; text-align: right;"" & @CRLF & _
"style="display: block; text-align: right;'" & @CRLF & _
"style="display: block; text-align:right;"" & @CRLF & _
"style='display: block; text-align:right;'" & @CRLF & _
"style="display: block;text-align: right"" & @CRLF & _
"style='display: block;text-align: right'" & @CRLF & _
"style='display: block;text-align: right"" & @CRLF & _
"style="display: block;text-align: right'" & @CRLF & _
"style="display: block;text-align:right"" & @CRLF & _
"style='display: block;text-align:right'" & @CRLF & _
"style="display: block;text-align: right;"" & @CRLF & _
"style='display: block;text-align: right;'" & @CRLF & _
"style='display: block;text-align: right;"" & @CRLF & _
"style="display: block;text-align: right;'" & @CRLF & _
"style="display: block;text-align:right;"" & @CRLF & _
"style='display: block;text-align:right;'" & @CRLF & _
"style="display:block;text-align: right"" & @CRLF & _
"style='display:block;text-align: right'" & @CRLF & _
"style='display:block;text-align: right"" & @CRLF & _
"style="display:block;text-align: right'" & @CRLF & _
"style="display:block;text-align:right"" & @CRLF & _
"style='display:block;text-align:right'" & @CRLF & _
"style="display:block;text-align: right;"" & @CRLF & _
"style='display:block;text-align: right;'" & @CRLF & _
"style='display:block;text-align: right;"" & @CRLF & _
"style="display:block;text-align: right;'" & @CRLF & _
"style="display:block;text-align:right;"" & @CRLF & _
"style='display:block;text-align:right;'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")