import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "style=\\\"\\s?.*?text-align:\\s?(.*?);?\\\"|style=\\'\\s?.*?text-align:\\s?(.*?);?\\'";
final String string = "style=\"text-align: right\"\n"
+ "style='text-align: right'\n"
+ "style='text-align: right\"\n"
+ "style=\"text-align: right'\n"
+ "style=\"text-align:right\"\n"
+ "style='text-align:right'\n"
+ "style=\"text-align: right;\"\n"
+ "style='text-align: right;'\n"
+ "style='text-align: right;\"\n"
+ "style=\"text-align: right;'\n"
+ "style=\"text-align:right;\"\n"
+ "style='text-align:right;'\n"
+ "style=\"display: block; text-align: right\"\n"
+ "style='display: block; text-align: right'\n"
+ "style='display: block; text-align: right\"\n"
+ "style=\"display: block; text-align: right'\n"
+ "style=\"display: block; text-align:right\"\n"
+ "style='display: block; text-align:right'\n"
+ "style=\"display: block; text-align: right;\"\n"
+ "style='display: block; text-align: right;'\n"
+ "style='display: block; text-align: right;\"\n"
+ "style=\"display: block; text-align: right;'\n"
+ "style=\"display: block; text-align:right;\"\n"
+ "style='display: block; text-align:right;'\n"
+ "style=\"display: block;text-align: right\"\n"
+ "style='display: block;text-align: right'\n"
+ "style='display: block;text-align: right\"\n"
+ "style=\"display: block;text-align: right'\n"
+ "style=\"display: block;text-align:right\"\n"
+ "style='display: block;text-align:right'\n"
+ "style=\"display: block;text-align: right;\"\n"
+ "style='display: block;text-align: right;'\n"
+ "style='display: block;text-align: right;\"\n"
+ "style=\"display: block;text-align: right;'\n"
+ "style=\"display: block;text-align:right;\"\n"
+ "style='display: block;text-align:right;'\n"
+ "style=\"display:block;text-align: right\"\n"
+ "style='display:block;text-align: right'\n"
+ "style='display:block;text-align: right\"\n"
+ "style=\"display:block;text-align: right'\n"
+ "style=\"display:block;text-align:right\"\n"
+ "style='display:block;text-align:right'\n"
+ "style=\"display:block;text-align: right;\"\n"
+ "style='display:block;text-align: right;'\n"
+ "style='display:block;text-align: right;\"\n"
+ "style=\"display:block;text-align: right;'\n"
+ "style=\"display:block;text-align:right;\"\n"
+ "style='display:block;text-align:right;'";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}