// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z0-9\-_]){1,254}$").unwrap();
let string = "test
works
1works
works2
Fine
isFine
is_fine
is-fine
not fine
shouldn'twork";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}