package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Za-z0-9\-_]){1,254}$`)
var str = `test
works
1works
works2
Fine
isFine
is_fine
is-fine
not fine
shouldn'twork`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}