$re = '/^([A-Za-z0-9\-_]){1,254}$/m';
$str = 'test
works
1works
works2
Fine
isFine
is_fine
is-fine
not fine
shouldn\'twork';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);