import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z0-9\\-_]){1,254}$";
final String string = "test\n"
+ "works\n"
+ "1works\n"
+ "works2\n"
+ "Fine\n"
+ "isFine\n"
+ "is_fine\n"
+ "is-fine\n"
+ "not fine\n"
+ "shouldn'twork";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}