#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z0-9\-_]){1,254}$"
Local $sString = "test" & @CRLF & _
"works" & @CRLF & _
"1works" & @CRLF & _
"works2" & @CRLF & _
"Fine" & @CRLF & _
"isFine" & @CRLF & _
"is_fine" & @CRLF & _
"is-fine" & @CRLF & _
"not fine" & @CRLF & _
"shouldn'twork"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")