const regex = /^([A-Za-z0-9\-_]){1,254}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z0-9\\-_]){1,254}$', 'gm')
const str = `test
works
1works
works2
Fine
isFine
is_fine
is-fine
not fine
shouldn'twork`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}