re = /^([A-Za-z0-9\-_]){1,254}$/m
str = 'test
works
1works
works2
Fine
isFine
is_fine
is-fine
not fine
shouldn\'twork'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end