import Foundation
let pattern = #"^https:\/\/www\.own3d\.tv\/en\/product\/[a-zA-Z0-9-\/]*-series-[a-zA-Z0-9-\/]*\/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
select all english detail pages of overlay packages
starting with: https://www.own3d.tv/en/product/
containing between various characters: -series-
-------------------------------------------------------
https://www.own3d.tv/en/product/arcadepro-series-package/
https://www.own3d.tv/en/product/dj-series-package/
https://www.own3d.tv/en/
https://www.own3d.tv/en/product/8-pack-animated-reaper-twitch-emotes-sales-bundle/
https://www.own3d.tv/en/product/twitch-channel-points-ghost/
https://www.own3d.tv/de/produkt/nexus-series-package/
https://www.own3d.tv/pt-br/produto/nexus-series-package/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)