re = /^https:\/\/www\.own3d\.tv\/en\/product\/[a-zA-Z0-9-\/]*-series-[a-zA-Z0-9-\/]*\/?$/m
str = 'select all english detail pages of overlay packages
starting with: https://www.own3d.tv/en/product/
containing between various characters: -series-
-------------------------------------------------------
https://www.own3d.tv/en/product/arcadepro-series-package/
https://www.own3d.tv/en/product/dj-series-package/
https://www.own3d.tv/en/
https://www.own3d.tv/en/product/8-pack-animated-reaper-twitch-emotes-sales-bundle/
https://www.own3d.tv/en/product/twitch-channel-points-ghost/
https://www.own3d.tv/de/produkt/nexus-series-package/
https://www.own3d.tv/pt-br/produto/nexus-series-package/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end