use strict;
my $str = 'select all english detail pages of overlay packages
starting with: https://www.own3d.tv/en/product/
containing between various characters: -series-
-------------------------------------------------------
https://www.own3d.tv/en/product/arcadepro-series-package/
https://www.own3d.tv/en/product/dj-series-package/
https://www.own3d.tv/en/
https://www.own3d.tv/en/product/8-pack-animated-reaper-twitch-emotes-sales-bundle/
https://www.own3d.tv/en/product/twitch-channel-points-ghost/
https://www.own3d.tv/de/produkt/nexus-series-package/
https://www.own3d.tv/pt-br/produto/nexus-series-package/';
my $regex = qr/^https:\/\/www\.own3d\.tv\/en\/product\/[a-zA-Z0-9-\/]*-series-[a-zA-Z0-9-\/]*\/?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}