using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/www\.own3d\.tv\/en\/product\/[a-zA-Z0-9-\/]*-series-[a-zA-Z0-9-\/]*\/?$";
string input = @"select all english detail pages of overlay packages
starting with: https://www.own3d.tv/en/product/
containing between various characters: -series-
-------------------------------------------------------
https://www.own3d.tv/en/product/arcadepro-series-package/
https://www.own3d.tv/en/product/dj-series-package/
https://www.own3d.tv/en/
https://www.own3d.tv/en/product/8-pack-animated-reaper-twitch-emotes-sales-bundle/
https://www.own3d.tv/en/product/twitch-channel-points-ghost/
https://www.own3d.tv/de/produkt/nexus-series-package/
https://www.own3d.tv/pt-br/produto/nexus-series-package/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}