import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/www\\.own3d\\.tv\\/en\\/product\\/[a-zA-Z0-9-\\/]*-series-[a-zA-Z0-9-\\/]*\\/?$";
final String string = "select all english detail pages of overlay packages\n"
+ "starting with: https://www.own3d.tv/en/product/\n"
+ "containing between various characters: -series-\n"
+ "-------------------------------------------------------\n"
+ "https://www.own3d.tv/en/product/arcadepro-series-package/\n"
+ "https://www.own3d.tv/en/product/dj-series-package/\n"
+ "https://www.own3d.tv/en/\n"
+ "https://www.own3d.tv/en/product/8-pack-animated-reaper-twitch-emotes-sales-bundle/\n"
+ "https://www.own3d.tv/en/product/twitch-channel-points-ghost/\n"
+ "https://www.own3d.tv/de/produkt/nexus-series-package/\n"
+ "https://www.own3d.tv/pt-br/produto/nexus-series-package/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}