// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/www\.own3d\.tv\/en\/product\/[a-zA-Z0-9-\/]*-series-[a-zA-Z0-9-\/]*\/?$").unwrap();
let string = "select all english detail pages of overlay packages
starting with: https://www.own3d.tv/en/product/
containing between various characters: -series-
-------------------------------------------------------
https://www.own3d.tv/en/product/arcadepro-series-package/
https://www.own3d.tv/en/product/dj-series-package/
https://www.own3d.tv/en/
https://www.own3d.tv/en/product/8-pack-animated-reaper-twitch-emotes-sales-bundle/
https://www.own3d.tv/en/product/twitch-channel-points-ghost/
https://www.own3d.tv/de/produkt/nexus-series-package/
https://www.own3d.tv/pt-br/produto/nexus-series-package/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}