# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https:\/\/www\.own3d\.tv\/en\/product\/[a-zA-Z0-9-\/]*-series-[a-zA-Z0-9-\/]*\/?$"
test_str = ("select all english detail pages of overlay packages\n"
"starting with: https://www.own3d.tv/en/product/\n"
"containing between various characters: -series-\n"
"-------------------------------------------------------\n"
"https://www.own3d.tv/en/product/arcadepro-series-package/\n"
"https://www.own3d.tv/en/product/dj-series-package/\n"
"https://www.own3d.tv/en/\n"
"https://www.own3d.tv/en/product/8-pack-animated-reaper-twitch-emotes-sales-bundle/\n"
"https://www.own3d.tv/en/product/twitch-channel-points-ghost/\n"
"https://www.own3d.tv/de/produkt/nexus-series-package/\n"
"https://www.own3d.tv/pt-br/produto/nexus-series-package/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.