// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:smiley(creations15)?|Smiley)\b").unwrap();
let string = "smileycreations15 - ok
smiley - ok
Smiley - ok
Smileycreations15 - not ok because first letter is capital";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}