$re = '/\b(?:smiley(creations15)?|Smiley)\b/';
$str = 'smileycreations15 - ok
smiley - ok
Smiley - ok
Smileycreations15 - not ok because first letter is capital';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);