using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:smiley(creations15)?|Smiley)\b";
string input = @"smileycreations15 - ok
smiley - ok
Smiley - ok
Smileycreations15 - not ok because first letter is capital";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}