re = /\b(?:smiley(creations15)?|Smiley)\b/
str = 'smileycreations15 - ok
smiley - ok
Smiley - ok
Smileycreations15 - not ok because first letter is capital'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end