#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:smiley(creations15)?|Smiley)\b"
Local $sString = "smileycreations15 - ok" & @CRLF & _
"smiley - ok" & @CRLF & _
"Smiley - ok" & @CRLF & _
"Smileycreations15 - not ok because first letter is capital"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")