package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:smiley(creations15)?|Smiley)\b`)
var str = `smileycreations15 - ok
smiley - ok
Smiley - ok
Smileycreations15 - not ok because first letter is capital`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}