import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:smiley(creations15)?|Smiley)\\b";
final String string = "smileycreations15 - ok\n"
+ "smiley - ok\n"
+ "Smiley - ok\n"
+ "Smileycreations15 - not ok because first letter is capital";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}