import Foundation
let pattern = #"^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[^\s])[A-Za-z\d^\s]{8,}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Blablabla
Bj4
Vj4kl4kzgf9G
VjklkzgfG
VjklkzgfG_
Blablabla4
blablabla4
bdasDSADAsd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)