$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[^\s])[A-Za-z\d^\s]{8,}$/';
$str = 'Blablabla
Bj4
Vj4kl4kzgf9G
VjklkzgfG
VjklkzgfG_
Blablabla4
blablabla4
bdasDSADAsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);