using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[^\s])[A-Za-z\d^\s]{8,}$";
string input = @"Blablabla
Bj4
Vj4kl4kzgf9G
VjklkzgfG
VjklkzgfG_
Blablabla4
blablabla4
bdasDSADAsd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}