re = /^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[^\s])[A-Za-z\d^\s]{8,}$/
str = 'Blablabla
Bj4
Vj4kl4kzgf9G
VjklkzgfG
VjklkzgfG_
Blablabla4
blablabla4
bdasDSADAsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end