#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[^\s])[A-Za-z\d^\s]{8,}$"
Local $sString = "Blablabla" & @CRLF & _
"Bj4" & @CRLF & _
"Vj4kl4kzgf9G" & @CRLF & _
"VjklkzgfG" & @CRLF & _
"VjklkzgfG_" & @CRLF & _
"Blablabla4" & @CRLF & _
"blablabla4" & @CRLF & _
"bdasDSADAsd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")