import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[^\\s])[A-Za-z\\d^\\s]{8,}$";
final String string = "Blablabla\n"
+ "Bj4\n"
+ "Vj4kl4kzgf9G\n"
+ "VjklkzgfG\n"
+ "VjklkzgfG_\n"
+ "Blablabla4\n"
+ "blablabla4\n"
+ "bdasDSADAsd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}