const regex = new RegExp('^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[^\\s])[A-Za-z\\d^\\s]{8,}$', 'g')
const str = `Blablabla
Bj4
Vj4kl4kzgf9G
VjklkzgfG
VjklkzgfG_
Blablabla4
blablabla4
bdasDSADAsd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}