import Foundation
let pattern = #"(https?:\/\/.*)(:\d*)\/?(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://some.domain.biz:8320/path/to/there/123456"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)