using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/.*)(:\d*)\/?(.*)";
string substitution = @"$1/$3";
string input = @"https://some.domain.biz:8320/path/to/there/123456";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}