package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/.*)(:\d*)\/?(.*)`)
var str = `https://some.domain.biz:8320/path/to/there/123456`
var substitution = "$1/$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}