# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?:\\/\\/.*)(:\d*)\\/?(.*)/$1\/$3/gm;t' <<< "https://some.domain.biz:8320/path/to/there/123456"