use strict;
my $str = 'https://some.domain.biz:8320/path/to/there/123456';
my $regex = qr/(https?:\/\/.*)(:\d*)\/?(.*)/mp;
my $subst = '$1/$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";