#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(https?:\/\/.*)(:\d*)\/?(.*)"
Local $sString = "https://some.domain.biz:8320/path/to/there/123456"
Local $sSubst = "$1/$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)