const regex = /(https?:\/\/.*)(:\d*)\/?(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/.*)(:\\d*)\\\/?(.*)', 'gm')
const str = `https://some.domain.biz:8320/path/to/there/123456`;
const subst = `$1/$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);