// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\/hub\/([0-9a-zA-Z-]*)(\/.*)?").unwrap();
let string = "/hub/xxx/test
/hub/xxx
/hub/xxx/abc/123/24
/hub/e0598b42-a9b0-4214-8533-4c031975348e/test/potato/?wor";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}