using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/hub\/([0-9a-zA-Z-]*)(\/.*)?";
string input = @"/hub/xxx/test
/hub/xxx
/hub/xxx/abc/123/24
/hub/e0598b42-a9b0-4214-8533-4c031975348e/test/potato/?wor";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}