$re = '/^\/hub\/([0-9a-zA-Z-]*)(\/.*)?/';
$str = '/hub/xxx/test
/hub/xxx
/hub/xxx/abc/123/24
/hub/e0598b42-a9b0-4214-8533-4c031975348e/test/potato/?wor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);