const regex = /^\/hub\/([0-9a-zA-Z-]*)(\/.*)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/hub\\\/([0-9a-zA-Z-]*)(\\\/.*)?', 'g')
const str = `/hub/xxx/test
/hub/xxx
/hub/xxx/abc/123/24
/hub/e0598b42-a9b0-4214-8533-4c031975348e/test/potato/?wor`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}