import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/hub\\/([0-9a-zA-Z-]*)(\\/.*)?";
final String string = "/hub/xxx/test\n"
+ "/hub/xxx\n"
+ "/hub/xxx/abc/123/24\n"
+ "/hub/e0598b42-a9b0-4214-8533-4c031975348e/test/potato/?wor";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}