#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\/hub\/([0-9a-zA-Z-]*)(\/.*)?"
Local $sString = "/hub/xxx/test" & @CRLF & _
"/hub/xxx" & @CRLF & _
"/hub/xxx/abc/123/24" & @CRLF & _
"/hub/e0598b42-a9b0-4214-8533-4c031975348e/test/potato/?wor"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")