re = /^\/hub\/([0-9a-zA-Z-]*)(\/.*)?/
str = '/hub/xxx/test
/hub/xxx
/hub/xxx/abc/123/24
/hub/e0598b42-a9b0-4214-8533-4c031975348e/test/potato/?wor'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end