// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\/video\/{2}.+)\/").unwrap();
let string = "/video//breaking/
/video/breaking/
/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/
^(\\/video\\/.+)\\/$
^(?=.{4,15}$)\\w{2,}\\s\\w{2,}$
/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;
(?<parent>((?i)\\/video\\/(?-i)))(?<child>((?i)\\/d\\/(?-i)))
((?<One>\\/\\w*video\\w*\\/)\\d+)?(?<Two>xyz)(.*)
^.*\\b(one|two|three)\\b.*$
^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*$
(?=.*?\\bmandatory\\b)
((?!avoid|illegal).)*$
^(?=.*?(\\/\\bvideo\\b\\/.+\\/))$
(\\/video(?=\\/)\\/(?=\\w))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}