import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/video\\/{2}.+)\\/";
final String string = "/video//breaking/\n\n"
+ "/video/breaking/\n\n"
+ "/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/\n\n"
+ "^(\\/video\\/.+)\\/$\n\n"
+ "^(?=.{4,15}$)\\w{2,}\\s\\w{2,}$\n\n"
+ "/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;\n\n"
+ "(?<parent>((?i)\\/video\\/(?-i)))(?<child>((?i)\\/d\\/(?-i)))\n\n"
+ "((?<One>\\/\\w*video\\w*\\/)\\d+)?(?<Two>xyz)(.*)\n\n"
+ "^.*\\b(one|two|three)\\b.*$\n\n"
+ "^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*$\n\n"
+ "(?=.*?\\bmandatory\\b)\n\n"
+ "((?!avoid|illegal).)*$\n\n"
+ "^(?=.*?(\\/\\bvideo\\b\\/.+\\/))$\n\n"
+ "(\\/video(?=\\/)\\/(?=\\w))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}