use strict;
my $str = '/video//breaking/
/video/breaking/
/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/
^(\\/video\\/.+)\\/$
^(?=.{4,15}$)\\w{2,}\\s\\w{2,}$
/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;
(?<parent>((?i)\\/video\\/(?-i)))(?<child>((?i)\\/d\\/(?-i)))
((?<One>\\/\\w*video\\w*\\/)\\d+)?(?<Two>xyz)(.*)
^.*\\b(one|two|three)\\b.*$
^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*$
(?=.*?\\bmandatory\\b)
((?!avoid|illegal).)*$
^(?=.*?(\\/\\bvideo\\b\\/.+\\/))$
(\\/video(?=\\/)\\/(?=\\w))';
my $regex = qr/^(\/video\/{2}.+)\//mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}