const regex = /^(\/video\/{2}.+)\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\/video\\\/{2}.+)\\\/', 'gm')
const str = `/video//breaking/
/video/breaking/
/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/
^(\\/video\\/.+)\\/\$
^(?=.{4,15}\$)\\w{2,}\\s\\w{2,}\$
/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;
(?<parent>((?i)\\/video\\/(?-i)))(?<child>((?i)\\/d\\/(?-i)))
((?<One>\\/\\w*video\\w*\\/)\\d+)?(?<Two>xyz)(.*)
^.*\\b(one|two|three)\\b.*\$
^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*\$
(?=.*?\\bmandatory\\b)
((?!avoid|illegal).)*\$
^(?=.*?(\\/\\bvideo\\b\\/.+\\/))\$
(\\/video(?=\\/)\\/(?=\\w))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}